ThinkPHP6.0视图驱动扩展

ThinkPHP

在TP5.*系列中可以直接使用view()助手函数渲染模板,但是在ThinkPHP6.0中渲染模板文件必须先引入视图扩展才能正常使用,否则将会抛出错误,使用composer引入视图驱动即可解决:composer require topthink/think-view(视图驱动扩展)

辰风沐阳 阅读 761 2020-06-11

ThinkPHP6.0的下载和基本配置

ThinkPHP

ThinkPHP6.0只能通过Composer下载和更新,无法再像TP5一样使用Git下载,PHP版本要求 7.1.0+,相比TP5.*主要更新有:视图扩展扩展独立,渲染模板要先引入视图扩展,TP5中的模块在TP6中称为应用,使用多应用要先引入多应用扩展

辰风沐阳 阅读 841 2020-06-11

linux和window的不同之区分大小写

ThinkPHP linux

今天把本地项目放到线上报错,但是正常运行,看了下代码想起来是大小写的问题,window下不区分英文字母的大小写,而在Linux系统中严格区分英文字母的大小写

辰风沐阳 阅读 1036 2020-06-10