composer 安装扩展包时忽略版本匹配

Composer

执行 composer install 安装扩展包时遇到错误: Your requirements could not be resolved to an installable set of packages。这是因为当前PHP版本不匹配composer.json要求的版本,使用 --ignore-platform-reqs 参数可以忽略版本匹配

辰风沐阳 阅读 544 2021-10-31

jwt token 鉴权验证 【firebase 5.x】

PHP JWT Composer

JWT全称: JSON Web Token,以 token 的方式代替传统的cookie、session模式,用于各服务器、客户端传递信息及签名验证,本文记录在TP6.0中使用JWT作为token验证的示例。

辰风沐阳 阅读 2921 2021-09-20

TP6.0 使用 phpoffice/phpspreadsheet 导入数据

PHP ThinkPHP TP6.0 Composer

PhpSpreadsheet是一个用纯PHP编写的库,并引入了命名空间,PSR规范等。使用表格批量导入数据也是很常见的一种场景,本文记录在TP6.0中如何读取表格数据,将数据添加到数据库中。该扩展库要求PHP版本7.2+,和TP6.0版本要求一致

辰风沐阳 阅读 1052 2021-06-12

composer install、update、require 区别

PHP Composer

当本地存在 `composer.lock` 文件时, composer install 将会去读取 composer.lock 中存储的版本号, 并且以此标准去下载依赖; 而 composer update 则不会去读取 composer.lock 中的版本号, 他仍然会去读取 composer.json 中定义的依赖, 生成新的 composer.lock 文件

辰风沐阳 阅读 778 2021-06-03

composer search 搜索 packagist.org 依赖包

Composer

composer search 搜索 packagist.org 依赖包。应用场景:在TP框架中想引入TP官方的依赖包,忘记了包名或不想手打,可以先使用 search 命令搜索出来, 再将需要的依赖包复制到命令行中安装

辰风沐阳 阅读 576 2021-05-17

phpoffice/phpexcel 读取Excel表格数据

PHP Composer

PHP版本7.2以下推荐使用 phpoffice/phpexcel 读取表格数据

辰风沐阳 阅读 853 2021-04-06

nesbot/carbon 日期时间处理扩展包

PHP Composer

应用场景: 根据时间戳出计算到现在的时间: 刚刚, 1分钟前

辰风沐阳 阅读 838 2021-04-04

phpoffice/phpexcel 导出Excel表格数据

PHP Composer

导出Excel表格适用场景: 导出订单,导出用户信息; PHP7.2版本以下推荐使用 phpoffice/phpexcel(TP5.0,TP5.1),PHP7.2版本以上推荐使用 phpoffice/phpspreadsheet(TP6.0),phpoffice/phpexcel 已经停止维护

辰风沐阳 阅读 1082 2021-04-04

常用 Composer扩展包

Composer

本文记录一些好用的composer包,找到好的扩展包,开发中能够大大提高开发效率。相信本文一定有你需要的扩展包

辰风沐阳 阅读 1617 2021-01-02

Composer 使用缩略名调用命令

Composer

缩略名调用命令的前提:这个缩略名具有唯一性,不会混淆;否则会报错,示例:`composer in` Command "in" is ambiguous (init, install and 1 more).【命令“in”不明确(init、install和1个以上)】

辰风沐阳 阅读 806 2020-10-10